laptop monitor black/purple after boot since update

Questions about hardware, drivers and peripherals.
In the Original Post please also include the output of inxi -Fzx
duped
Posts: 43
Joined: 17 Jan 2014 17:29
Location: Quebec, Canada

laptop monitor black/purple after boot since update

Postby duped » 05 Mar 2015 18:00

Solydk-BE

My laptop had an uptime of about 30 days until yesterday when I accidently pulled the battery lock swtich and it fell out so the machine lost power. I had been installing updates in the meantime but upon startup, nothing would display on the laptop screen. It seems that others are having problems with plymouth update this month, I wonder if it is related.

The laptop screen will not display but has a purplish light also it will still run my older solydk display (from about early Jan), i.e the screen is working fine. I have a docking station with monitor and tried it there to discover that they system is on and working and think it is using the display but shows nothing. I need to go into display settings and clone the screens and can only work on my monitor but not laptop screen. However this is still not working correctly because big flashing black box starting from the bottom covers the screen up to the mouse pointer (I am sure this is to due to cloning displays of different resolutions, but I am not too worried about this presently, I just offer it as a potential diagnostic). xrandr and kde display show that the monitor is connected at the proper resolution, however.

If disconnected from the monitor nothing will display on the laptop screen, even upon fresh startup.

other info:

in virtual terminal a message given
"xset unable to open to display "" "

I have tried the "noplymouth", "nomodeset" and "nosplash" options in grub but it makes no difference.

Any help appreciated to get the laptop screen working in particular.

Code: Select all

~$ inxi -F
System:    Host:    Kernel: 3.2.0-4-amd64 x86_64 (64 bit) Desktop: KDE 4.8.4 Distro: SolydXK 1 testing 
Machine:   System: Dell product: Latitude E6320 v: 01
           Mobo: Dell model: 05VMY6 v: A00 Bios: Dell v: A17 date: 03/07/2013
CPU:       Dual core Intel Core i5-2520M (-HT-MCP-) cache: 3072 KB 
           Clock Speeds: 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.Org 1.12.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.0hz, 1680x1050@59.9hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 8.0.5
Audio:     Card-1 Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel 
           Card-2 Logitech Clear Chat Comfort USB Headset driver: USB Audio 
           Sound: Advanced Linux Sound Architecture v: 1.0.24
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: eth1 state: up speed: 100 Mbps duplex: full mac: d4:be:d9:23:bf:42
           Card-2: Broadcom BCM43228 802.11a/b/g/n driver: wl
           IF: wlan0 state: dormant mac: 08:ed:b9:0e:b4:5c
Drives:    HDD Total Size: 560.1GB (25.8% used) ID-1: /dev/sda model: WDC_WD3200BEKT size: 320.1GB
           ID-2: /dev/sdb model: Crucial_CT240M50 size: 240.1GB
Partition: ID-1: / size: 21G used: 12G (59%) fs: ext4 dev: /dev/sdb1 
           ID-2: /home size: 198G used: 120G (64%) fs: ext4 dev: /dev/sdb2 
           ID-3: swap-1 size: 4.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 146 Uptime: 10 min Memory: 1129.7/7885.8MB Client: Shell (bash) inxi: 2.1.28


Return to “Hardware”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests