DDM y FAIL startpar: service(s) returned failure: plymouth .

User avatar
anxova
Posts: 52
Joined: 20 Mar 2013 20:42
Location: Narón, Spain
Contact:

DDM y FAIL startpar: service(s) returned failure: plymouth .

Postby anxova » 08 Sep 2013 02:20

He instalado la versión última de SolydX en un ordenador que funcionaba muy bien con versiones anteriores de SolydX. en principio todo iba bien hasta que haciendo caso a la recomendación de DDM, instalé el driver nVidia en lugar de nouveau. Entonces el arranque se detiene en este mensaje:

[FAIL] startpar: service(s) returned failure: plymouth ... failed!

Creyendo que el problema estaba en el driver nvidia desinstalé desde la consola (pulsando ctrl-alt-F1) todo lo que sonase a nvidia aplicando sudo apt-get remove nvidia*

Compruebo que el driver nouveau continúa instalado y reinicio.

Pues bien, sigue el fastidioso mensaje y el sistema parado.

Ya es la segunda vez que me ocurre. Creí haber instalado una versión defectuosa de solydx, por lo que reinstalé y al caer de nuevo en la tentación de hacer caso a DDM vuelve a pasarme lo mismo.

El caso es que no he encontrado demasiada información sobre este problema en internet, pues todo el mundo acaba reinstalando cuando pasa esto. Tan solo en este foro, en una sección sobre DDM encontré una recomendación de Schoelje sobre un problema análogo pero con el driver para ATI.

Me gustaría poder solucionar esto sin reinstalar, a ser posible, pues ya había empezado a personalizar mi linux.

Saludos y me alegro de volver por aquí, he acabado volviendo a Mint KDE (versión ubuntera) en mi portátil, pero sigo fiel a Solyd en otros ordenadores.
Anxo Varela
Painter, calligrapher, designer. Minter becoming debianite.

Sony VAIO VGN-FZ21Z --> Linux Mint 15 KDE
Toshiba NB200-14Q --> LMDE Mate 32 + XFCE 4.10
AMD Sempron 2800+ --> SolydX 32 + Windows XP

User avatar
anxova
Posts: 52
Joined: 20 Mar 2013 20:42
Location: Narón, Spain
Contact:

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby anxova » 08 Sep 2013 02:48

Parece que empieza a arreglarse el problema editando el archivo /etc/X11/xorg.conf
Cambié en la sección "device"
Driver "nvidia" por Driver "nouveau"

En principio me aparece la pantalla con una resolución muy baja, pero creo que eso lo podré solucionar más fácilmente.

Estoy seguro de que esto ha funcionado un poco por casualidad. Pero en fin, al menos estoy de nuevo en el escritorio y desde ahí supongo que será más fácil reparar todo.
Anxo Varela
Painter, calligrapher, designer. Minter becoming debianite.

Sony VAIO VGN-FZ21Z --> Linux Mint 15 KDE
Toshiba NB200-14Q --> LMDE Mate 32 + XFCE 4.10
AMD Sempron 2800+ --> SolydX 32 + Windows XP

User avatar
Arjen Balfoort
Site Admin
Posts: 9472
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby Arjen Balfoort » 09 Sep 2013 10:30

Sorry, this one in English (don't have much time):
If you remove/rename /etc/X11/xorg.conf, your system will choose the best driver available.
You need to check the files in /etc/modprobe.d/ whether nouveau is blacklisted.
If so, remove the blacklist line.


SolydXK needs you!
Development | Testing | Translations

User avatar
anxova
Posts: 52
Joined: 20 Mar 2013 20:42
Location: Narón, Spain
Contact:

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby anxova » 09 Sep 2013 12:18

Thank you, Schoelje, I've deleted xorg.conf this morning and now the computer works fine.

Gracias, Schoelje, he borrado xorg.conf esta mañana y ahora el ordenador funciona bien.

Sigo en español, no quiero aumentar el ridículo patrio del sábado chapurrando en inglés :twisted:

Estaba pensando que puedo probar lo siguiente:
1. Abrir DDM y dejar que instale el driver nvidia recomendado.
2. Como se atascará en el inicio (FAIL startpar...) abrir una consola y borrar xorg.conf
3. Arrancar de nuevo y ver si entonces inicia con el driver nvidia instalado desde DDM

Si no funciona, simplemente desinstalo de nuevo los drivers privativos y vuelvo a borrar xorg.conf para recuperar nouveau.

Una pregunta: ¿la nueva versión que liberarás el día 13 tendrá solucionado este bug?

Muchas gracias de antemano, es un lujo poderte hablar directamente y encima en español.
Anxo Varela
Painter, calligrapher, designer. Minter becoming debianite.

Sony VAIO VGN-FZ21Z --> Linux Mint 15 KDE
Toshiba NB200-14Q --> LMDE Mate 32 + XFCE 4.10
AMD Sempron 2800+ --> SolydX 32 + Windows XP

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby zerozero » 09 Sep 2013 12:38

sorry for being again in english, im in the phone and without auto-correction i dont dare to write in spanish :)

this is a bug in plymouth, in debian-plymouth-manager choose none as the plymouth theme and i believe that you can use the nvidia drivers without problems.


intentando ahora en castellano
este es un error en Plymouth, en el debian-plymouth-manager usted elija <none> como el tema de plymouth Y yo creo que usted puede utilizar los controladores de nvidia sin problemas.
Last edited by zerozero on 09 Sep 2013 23:42, edited 2 times in total.
Reason: added spanish text
bliss of ignorance

User avatar
anxova
Posts: 52
Joined: 20 Mar 2013 20:42
Location: Narón, Spain
Contact:

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby anxova » 09 Sep 2013 13:36

Snif... qué pena :( ¡Con lo que me gustaba que al fin funcionase Plymouth!
Pues nada, probaré, gracias de nuevo.
Anxo Varela
Painter, calligrapher, designer. Minter becoming debianite.

Sony VAIO VGN-FZ21Z --> Linux Mint 15 KDE
Toshiba NB200-14Q --> LMDE Mate 32 + XFCE 4.10
AMD Sempron 2800+ --> SolydX 32 + Windows XP

jonasgamma
Posts: 42
Joined: 20 Jun 2013 06:27
Location: Medellín, Colombia

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby jonasgamma » 10 Sep 2013 20:27

También tuve el mismo problema pero se soluciona abriendo el plymouth manager y escogiendo sin plymouth, queda menos elegante pero es mejor.

Gustavo
Posts: 4
Joined: 16 Oct 2013 05:13

Re: DDM y FAIL startpar: service(s) returned failure: plymou

Postby Gustavo » 19 Oct 2013 17:15

Yo tenía el mismo problema, pero podía arrancar normalmente con el entorno gráfico.
El mensaje de error de plymouth se fue al instalar el siguiente paquete plymouth-themes-all.

Intenta desde consola con:

sudo apt-get install plymouth-themes-all

Espero sea la solución.

Saludos desde San Juan, Argentina


Return to “Español”

Who is online

Users browsing this forum: No registered users and 1 guest